当前位置: 首页 > 技术资料 > dedecms >

dedecms织梦文档关键词维护不起作用php版本太高修

时间:2019-07-09 16:15来源:信科网络 作者:淄博信科网络科技有限公司
// 这里可能会有错误
if (version_compare(PHP_VERSION, '5.5.0', '>='))
{
$body = @preg_replace_callback("#(^|>)([^<]+)(?=<|$)#sU", "_highlight('\\2', \$karr, \$kaarr, '\\1')", $body);
} else {
$body = @preg_replace("#(^|>)([^<]+)(?=<|$)#sUe", "_highlight('\\2', \$karr, \$kaarr, '\\1')", $body);
}

//恢复超链接
$body = preg_replace("#(<a(.*))-\]-(.*)-\[-(\/a>)#isU", '\\1>\\3<\\4', $body);
return $body;

改成

if (version_compare(PHP_VERSION, '7.5.0', '>='))
{
$body = @preg_replace_callback("#(^|>)([^<]+)(?=<|$)#sU", "_highlight('\\2', \$karr, \$kaarr, '\\1')", $body);
} else {
$body = @preg_replace("#(^|>)([^<]+)(?=<|$)#sUe", "_highlight('\\2', \$karr, \$kaarr, '\\1')", $body);
}

//恢复超链接
$body = preg_replace("#(<a(.*))-\]-(.*)-\[-(\/a>)#isU", '\\1>\\3<\\4', $body);
return $body;

修改这个文件include/arc.archives.class  共修改2行
只需要把  PHP_VERSION, '5.5.0', '>='   里面的第一个5改成7就ok了

一共是2处,可以用查询功能修改下,修改好后生成以下全站, 里面的内联是不是就可以展现了?问题解决了

标签:

本文网址:https://www.chinaxinkekeji.com/dedecms/20190709/70.html
本文由 淄博信科网络 网发布( https://www.chinaxinkekeji.com ),如果您还想了解更多关于 淄博网站制作 淄博网站推广 的文章,请点击查看 淄博网站设计 的其它文章,转发请注明来源及版权归属。
承接以下业务:传统网站改自适应网站、网站增加手机站、网站改全屏网站改大屏展示、GBK转UFT-8、DEDECMS转WORDPRESS、dedecms织梦文档关键词维护不起作用php版本太高修网站站群制作、dedecms织梦文档关键词维护不起作用php版本太高修企业网站设计、dedecms织梦文档关键词维护不起作用php版本太高修企业网站优化、dedecms织梦文档关键词维护不起作用php版本太高修网站托管、仿站等业务

服务电话:
132-80692153

微信 13280692153
x

专注网站设计、网站推广

竞价网站、营销网站、H5自适应网站、小程序开发

承接网站代工、企业建站、网站SEO、整站优化